Google Aerial: "Sorry, we have no imagery here" - How to fix?

  • You might want to remove your API key from that link when you post it here.


    Anyways, you forgot to add ~x and ~y to the center parameter in the link, should look like this: ?center=~x,~y instead of ?center=0,0

    Ich hab mir zu Weihnachten gewünscht, das die Leute das lesen lernen würden. Ich wurde enttäuscht. :(

  • There are some changes, but not exactly good.

    So, I did replace 0,0 but the outcome was notwhat I expected.


    First, I tried to replace it with the actual center coordinates of my LOTUS map. (center=47,5603981018066,19,0898818969727)

    And it only repeated that one tile all over. (but at least the one I was looking for)


    In the second case, I replaced 0,0 with ~x,~y and this is what I got:

    (the line in the middle is some part of the USA according to the label on it which is totaly not what I was looking for)


    And I also tried removing "&key=..." part but it didn't seem to have an effect on the problem.


    P.s.: Sorry for my ignorance, I've never dealt with aerials until now.

  • I meant you should remove the key when you post the link in the forums, not when you try to use it for aerials.


    What I forgot to mention: Everytime you change the link, you have to clear the cache of the Mapeditor which you can find under "Steam\SteamApps\common\LOTUS-Simulator\Cache". Deleting the folder is enough.

    Ich hab mir zu Weihnachten gewünscht, das die Leute das lesen lernen würden. Ich wurde enttäuscht. :(

  • The ~x and ~y values from LOTUS will not work with the Google static maps. You will need to convert the tile numbers provided by LOTUS to Lat/Lon values expected by the Google API.


    I have written a small script that does this which you can use with your own API key.


    Code
    1. https://aerial.gcmods.de/toquad.php?x=~x&y=~y&z=~z&service=google&apicode=[API-Code]

    Just replace [API-Code] with your own.

  • I meant you should remove the key when you post the link in the forums, not when you try to use it for aerials.

    Oh, well... That wasn't my key, I got the link from another thread. But thanks, I'll keep this in mind in the future


    The ~x and ~y values from LOTUS will not work with the Google static maps. You will need to convert the tile numbers provided by LOTUS to Lat/Lon values expected by the Google API.


    I have written a small script that does this which you can use with your own API key.


    Code
    1. https://aerial.gcmods.de/toquad.php?x=~x&y=~y&z=~z&service=google&apicode=[API-Code]

    Just replace [API-Code] with your own.

    Thank you very much! I'm gonna try with this one!