Impossible to change sound packs of a vehicle

  • I'm working on a different variant of my vintage tram. Since it differs enough, I copied the already-published "Ezres", renamed it...etc, then tried to alter the sound packs (since I will change a few sounds and I don't want to rely on the Ezres' sound packs).

    But the program just simply doesn't allow me to. I open the sounds, click on the sound set, choose the one I want, then ask this question:

    But it doesn't matter what I click on, it keeps on the "Ezres_..." and not on the one I choose (MV_...). If I delete the Ezres_hangok lct file from my myObjects folder, it automatically sets the correct sound sets in the CT (I guess because they're the only sound sets made by me on my PC). It even works in the game. But as soon as I copy back the Ezres_hangok.lct (the original sound set package), and open the CT, it resets the sounds to this one (Ezres...) instead of the other one (MV...).

    I tried many methods. Not just resetting the package but renaming the "soundroom", saving, packaging the vehicle at different moments. Even I deleted the backpus and then retried if it helps, but it doesn't.

    I don't want to reset all of these triggers in the Content Tool by deleteing the soundrooms and making now ones (I'd have to add dozens of variables again...), so is there any way to set another sound set in the Content Tool? (I don't know, maybe it doesn't alter the needed parts of the lob file, or I don't know, since I cannot open any of the output files).

  • I think, the problem could be that your new sound set, which was a copy of your old one, has the same ContentID like the old one, right? ;-)

    So, just open the new sound pack, click here to get a new ContentID...


    save and pack it, go to your vehicle and try change it again. :-)

  • Wow, this actually solved the problem, thanks ^^

    (By the way, I didn't experience any odd with the vehicle, though it's also a copy - should I generate a new ID for it too?)

  • Actually I was wrong. I had to set a new content ID in the content tool, because this "train" was loaded if I chose the tram too (since it's a copy of it). After generating a new ID, it worked just fine.

  • Janine

    Closed the thread.
  • Janine

    Added the Label ContentTool
  • Janine

    Added the Label Solved