Text-texture not showing up

  • Hello again,

    Unfortunately, I now face another problem, that I hope You can help me solve.


    I created this part of a bus stop:


    and I need a text-texture for writing on the blue face.

    But no matter what I do, the text won't show at all, even with the built-in fonts. I use the "StreetNamesBerlin" font for testing.


    Settings in the Content Tool:


    And it all just leaves me with at transparent texture without any text:


    Adding a seperate offset plane with a seperate texture doesn't help much either.


    The script is exactly the same as in Florian's video tutorial. It's attached for reference.

    I've spent the whole day trying to troubleshoot this issue but without any luck. What am I doing wrong??


    - Thor

  • Hi,


    1. it's transparent because the original texture is replaced with the text texture (texID_draw). the solution is a second face in the exact same position (just copy the first one) which keeps the original material. the original needs to be placed above the one with the text in the list on the right side.


    2. you probably can't see any text here, because the orientation and vertical orientation are both set to center. the text is written in the center of the texture which seems to be outside of your mapping.

  • I tried remapping the texture of the extra face, so the UV fills the entire image, but it still won't work.

    I even tried with a simple cube (with extra face), but nope.


    Could it be an issue with the colour textures themselves? Wrong alpha data maybe?

  • Heureka, I did it!


    Apparently, it works now, whenever I try it out in the Map-Editor, after saving and packing the object with the correct text-texture settings.

    And then I tried opening it in Content Tool once again, this time as a saved .lob:


    And now it even works in there, too! My little "test cube" does as well.

    Before, I only imported the models directly without saving them as objects, and then immediately went for the script tester.

    From this, I can conclude (actually a very crucial step, maybe it should be specified somewhere??): The file needs to be saved once as a .lob, with all the settings, before the text will show up in any form.


    Sorry for me being that dumb :giggle: And thank you all for the help.


    Best regards,

    - Thor

  • Newly created posts will remain inaccessible for others until approved by a moderator.

    The last reply was more than 60 days ago, this thread is most likely obsolete. It is recommended to create a new thread instead.

    The maximum number of attachments: 5
    Maximum File Size: 500 kB
    Allowed extensions: bmp, cfg, ini, jpeg, jpg, lct, ldl, llg, lob, log, lpmtl, lptmt, ltx, pas, pdf, png, railtrack, rar, txt, veh, wav