Steam Workshop Upload problem

  • I always have a problem, if I want to upload anything to the Workshop from Content Tool. I choosed pictures, categories, name and descripton, but the COntent Tool never wants to upload my contents.(language files, sceneryobjects)

    I don't use plugins and modes.

    7. System information

    OS and architecture (32/64bit): WIndows 10 64 bit
    Processor: Intel 7700K

    Processor clock rat: 4,2 GHz (not overclocked)
    Processor cores: 4
    RAM: 2x8 GB Corsair RAM
    Type of hard drive (HDD/SSD/...) E driver(SSD: Samsung 850 Evo 256 GB)
    Desktop/Laptop/...: Desktop
    Graphic card name: Asus Geforce GTX 1050 Ti
    Graphic RAM: 4 GB
    Graphic Chip clock rate: 1290 MHz

    OpenGL Version (see LOTUS logfile): 4.6.0 NVIDIA 398.82

  • COntent Tool never wants

    And what does "want" mean? Error message? Missing entries/dialogues? Freezes?

    The Content Tool always write this message: (sorry I forgot to attach yesterday):

    It is interesting, because I am online and in different games I can upload contents to Steam Workshop

    Please create and attach a debug logfile of that problem.

    I watched this description, but it will be old, I don't find a lot of place, which was written in the post:

    And I don't understand what Can I do this step: (1.2 step)

    Edited once, last by Balzska: debug make problem ().

  • How many containers did you select for upload?

    I selected one container, but the Content Tool won't want to upload the container, but I can publish everything without attach the container(interesting):


  • I digged a little through the Steam forums since the failure message is something between "general failure" (which was given to LOTUS by the Steam server upon upload) and "file not found" as seen in the logs.

    Steam has some issues with special characters in context of workshop items. Please have a deeper look with this hint on your file names, especially of containers and even preview images. This may solve the problem...

    Another hint I found was to disable Firewall and AntiVir in order to test if it works.

    Edit: If you want to dig a little on your own, maybe in your native language in case it's a special character problem, you can use the key words "Steam workshop upload error 2" since that is the error message from the server.

  • I didn't used special characters, just English letters. I Tested without FIrewall and without Antivir Software, but it isn't solved the the problem... :/

    I attached new logfiles.

    Anyway, the is it a problem, if my Steam folder in C harddisk(HDD) and the LOTUS in E harddisk(SSD)?

  • Any special characters used in your upload files OR the preview images?

    Special characters are even á è î and so on...

    Yes. There are.

    I just try to remove and the transfer works!

  • Possible Fix


    Please exit Steam and go to the folder called C:\Program Files\Steam\ (this is the default location for a Steam installation - if you set a different installation directory, you will need to browse to it).

    Delete all of the files in this folder except:

    - Steamapps and Userdata folders

    - Steam.exe (this file is listed as an application and features the black and white Steam logo)

    Restart your computer.

    Then, launch Steam.exe from within the Steam installation folder, and not from a pre-existing shortcut.

    With Steam running, re-test the original issue.


    Windows + R > Type steam://flushconfig > Yes

    Maybe this works for you

  • I will test it on Sunday or Monday . I hope, it will be solve my problem :)

    (It didn't work in my state)

    I fixed my problem: The solution is Install the LOTUS-Simulator common harddisk with Steam. Before the problem the Steam was in C harddisk(HDD) and a LOTUS was in the E harddisk(SSD). I saved my content to a different folder, after I removed all LOTUS from my computer. I installed LOTUS again to C harddisk, so it is solved my problem and I copied my contents to the new LOTUS's folder.

    And it is solved a different problem: I can see my downloaded content from Workshop.

    The second problem was similar with my Garry's Mode's problem. I can't see my dowloaded contents in GM and I remembered the solution was the GM reinstall to common harddisk with STEAM, so I used this solution in this state.

    You can close the topic and thank you for your helps :)

  • Janine

    Closed the thread.
  • Janine

    Added the Label Steam
  • Janine

    Added the Label Workaround