Blender 2.8x and Blender 2.7x texture assignment method

  • Hello.

    I'm developer of "Daewoo bus lineup" for omsi. I'd made BS106, FX116 and so on.

    I'm South korean man and Maybe my english won't very well, but I ask for your understanding


    I'm preparing to start developing for Lotus and I found some errors with exporting X3D format.

    The structure of assigning texture is different by version of Blender.

    I founded this difference recently and researching how to overcoming the differences of texture assigning method.


    I have to work with almost 600 model object, anyone cannot do changing methods one by one. So I have to find something like Batch program, or plugins.

    I'll find out it either, but I want to ask at Lotus forum and have discuss about this version problems.


    Anyway, I succeed puting my model files into CDK, I put picture of my first X3D model.

    And I hope This thread is helpful who suffered with same errors.


  • Janine

    Approved the thread.
  • Blender 2.8 moved away from the internal Blender render to the cycles render. As a result the texture assignment process also changed. So far the x3d export addon has not been officially updated for this new process.

    The only change which has made it into the Blender 2.82 release that I noticed is the ability to export only the selected objects.


    I have started my own attempt at rectifying this with some success. Not every object I've tried can be successfully imported into the content tool without errors but from my limited testing most of my objects work while some don't.


    If you're interest in trying this out you can find the necessary information and file here: https://github.com/gcWorld/Blender-2.82-x3d-export/

    If you do, I'm very interested in any feedback about what works and what doesn't.

  • Glad to hear that you would like to develope for LOTUS! :-)

    Thank you for reply.


    I think the X3D Exporter is working well but the result was incorrect.

    The shape of mesh is exported well, the problem is the texture.

    In 2.79, It works just put in the texture files to mesh file without material.

    Even the Mesh which do not have any material can have texture in 2.79 environment.


    But in 2.8x, Meshes have to have at least one materials to assign texture files into mesh.

    Also the H3D extention function was expected to create textures from blender's shader but it did not work because of inappropriate coding structure.


    So maybe X3D exporter can not understand the structure of 2.8x's material structure, and it try to get texture files directly from mesh, ignoring all materials.

    It can be answer of this,

    If you do, I'm very interested in any feedback about what works and what doesn't.

    When I imported X3D file which from 2.8x, It's shape is correct but all of materials has no texture information.

    Also exporting imported 2.80's mesh does not worked at CDK either, showing message "partially or completely untextured".


    So The method is required which can help exporter to understand 2.8x's material structure, or assigning textures from materials automatically.

    I don't want to, and cannot to change all of my mesh's texture assignment. It will takes yearly time.


    Thanks for all of your efforts.