Content tool, script compiler malfunctioning (?)

  • I'm refactoring a vehicle script, and faced some issue. To be more precise, I have the globally declared, standard script event called "panto_0", which somehow was not identified by the compiler.

    Here's the codelet:

    And here's the error message:

    I tried everything. Placing the declaration up and down, making local copies...etc. Do you know what solved the compiling issue?

    You see, I added three dots in a comment. THAT was its problem. If I remove that comment line, everything works fine.

    I'm not a pascal magician, but is that really an intended behaviour?

    EDIT: after looking for info about commenting in pascal I found, that this kind of "//" commenting is not even the basic commenting style, comments should be in brackets/briefcases. After a bit of trying I start to think, that the LOTUS compiler simply doesn't eat multiline comments, or at least not in this format. My question is still valid though: is this intended or not?

  • Aham, I see. I learned the hard way, that in every programming situation, an expression error is made in real life by the succedor line, but I wouln't imagine that even comments can cause this. Guess I learned something new today. ;)

  • Newly created posts will remain inaccessible for others until approved by a moderator.

    The last reply was more than 60 days ago, this thread is most likely obsolete. It is recommended to create a new thread instead.

    The maximum number of attachments: 5
    Maximum File Size: 500 kB
    Allowed extensions: bmp, cfg, ini, jpeg, jpg, lct, ldl, llg, lob, log, lpmtl, lptmt, ltx, pas, pdf, png, railtrack, rar, txt, veh, wav