Can't use Shift + modifier for some Numpad keys

  • 1. Please describe as detailed as possible what you did and which problem that leads to.

    I tried to set my door control settings to the same as I have it set up in OMSI:


    Shift + Num 0: Open/close all doors
    Shift + Num 1 - Num 4: Open close 1 - 4 doors
    Shift + Num Enter: Station Brake


    However, I'm noticing that Shift + modifier only registers for some Num buttons, for others it doesn't register. (For example Num -, Num * and Num / accept Shift + modifier, but none of the number values or Num , doesn't register it).


    2. Please post your logfile and if possible attach your debug logfile, as well, which have been created during the problem occured.

    https://pastebin.com/hF1wnHVB


    3. If it is a performance or another possibly hardware-related problem, please post your system information. Those are:

    • OS and architecture (32/64bit)
      Windows 10 Pro 64bit version 1903
    • Processor clock rate
      Up to 4.10GHz
    • Processor cores
      6
    • RAM
      32GB DDR4
    • Type of hard drive (HDD/SDD)
      512GB NVMe SSD
      1TB SATA SSD
    • Desktop or Notebook?
      Notebook. Lenovo Y740-17ICH (First gen)
    • Name of your graphics card
      NVidia GeForce RTX 2070 Max-Q
    • Graphics memory
      8GB
    • GPU clock rate
      No idea
    • OpenGL version (see LOTUS logfile)
      4.6.0 NVIDIA 441.66

      Keyboard locale is set to Estonian/Eesti

    9896-groupfullwide2000px-png

    A virtual bus & trucking company.

    gogroupvirtual.eu

  • That's crazy - I can do that without any problems (with or without NumLock active)... ?/ Could you send us a few screenshots of your problem, perhaps there is something special to see...


    Does anybody else have such problems?

  • Ich hab das gleiche auch gestern festgestellt, als ich meine Steuerung zurückgesetzt habe & erneut einrichten wollte.

    Nach meiner Erinnerung konnte ich das in einer vorherigen Version aber problemlos einstellen.


  • That's crazy... just for info: You've tried to left [Shift] key, too? ;-)

    Yep.

    However, I now did further investigation at home, where I have external keyboard.
    If I have numlock off, then it works, but only with the external keyboard, because in case of the laptop keyboard (the one you saw on video), if numlock is disabled, then numpad is replaced with media keys (and I know some keyboards replace it with arrow keys etc).

    But yes, the strange thing is it's only shift. Ctrl, Alt all work in all modes.

    9896-groupfullwide2000px-png

    A virtual bus & trucking company.

    gogroupvirtual.eu

  • Newly created posts will remain inaccessible for others until approved by a moderator.

    The last reply was more than 60 days ago, this thread is most likely obsolete. It is recommended to create a new thread instead.

    The maximum number of attachments: 5
    Maximum File Size: 50 kB
    Allowed extensions: bmp, cfg, ini, jpeg, jpg, lct, ldl, llg, lob, log, lpmtl, lptmt, ltx, pas, pdf, png, railtrack, rar, txt, veh