Trigger aktivieren

  • Hallo zusammen,


    Zur Zeit kann man die Trigger durch die Tram aktivieren. z.B. zum Ansteuern einer Anforderung einer Ampel.

    Können die Trigger auch durch Busse aktiviert werden? Falls nein, kommt das noch? Oder muss ich für die Busse immer einen Anforderungstaster an der Ampel installieren?


    Vielen Dank für eure Hilfe

  • Das Thema passt genau zu mein Problem, muss ich keine weitere Frage aufmachen ^^


    Zum Trigger aktivieren, ich möchte mir eine Anforderung bauen mit Trigger.

    Ohne das ich bei der Tram ein Knöpfchen drücken muss, als beim überfahren des Triggers.

    Ich muss zugeben ich habe lange nicht mehr mit den Triggern gearbeitet, weil ich an meine Stadt baue.


    Ich weiß das es geht, dass eine Ampel nur dann auf Grün schaltet wenn die Tram den Trigger passiert.


    Ich habe die Ampel Einstellungen gemacht, dass sie dauerhaft Rot ist.

    Und nur mit nähern der Tram auf Grün schaltet, also durchs springen des Trigger.

    Habe das ganze im Trigger eingeben, und die Ampelleuchten zugeordnet.


    Aber es geht nicht, so oft wie ich es auch versuche.


    Zur Entwirrung, ein paar Bilder ^^°





  • Du musst der Ampel auch sagen, was sie tun soll wenn eine Anforderung kommt.

    Omsi hat mein Arbeitsplatz gekündigt, Putze ich halt bei Lotus :)


    Downtown [WIP]

    Mannheim 2021 [WIP]

  • Habe ich das nicht?

    Also ich habe es so verstanden, und auch eingestellt.

    Die Ampel soll 30 Sekunden grün sein.

    Und habe eine Sekunde auf Rot gestellt.

    Dann eine Springer Funktion eingebaut, die immer auf die 30. Sekunde springt.

    Also Rot bleibt.

    Und wenn ich mit der Tram über den Trigger fahre, sollte eigentlich der Springer unterbrochen werden.

    Und dann auf Grün gehen.



    Ergänzung:


    Eigentlich soll ja nur ein Signal aufleuchten, also Grün.

    Das Rot soll eigentlich nicht existieren, wusste aber nicht wie ich es sonst erklären soll.

  • Im Prinzip ist die Schaltung, wie Du sie hast, schon in Ordnung. Kommt keine Bahn, dann wird das Grün übersprungen, kommt eine, sollte das Grün abgespielt werden. Vorausgesetzt, der Triggerpunkt funktioniert. Das kannste vielleicht mal testen, indem Du auch einen Schlüsselschalter einbindest. Mich verwundert aber etwas, dass, wie im ersten Bild zu sehen, die Grünphase auch als Rot1 eingestellt ist? Übersehe ich da was?


    Weiterhin würde ich die Schaltung hier auch etwas anders gestalten, auch wenn es so wie es jetzt ist eigentlich gehen müsste. Und zwar würde ich den Sprung weglassen, und stattdessen einen Stoppunkt in die Rotphase legen. Ebenfalls mit dem Häkchen "Falls keine Anforderung vorliegt". So wartet die Anlage immer in Stellung rot, außer es kommt eine Anforderung, dann wird sofort (und nicht erst mit im schlimmsten Falle einer Sekunde Verzögerung wie bei Dir, ist Geschmackssache) die Grünphase durchlaufen.


    Weiterhin hat das den Vorteil, dass man einen lästigen Lotusbug des Ampelsystems umgeht. Marcel Kuhnt Vielleicht auch interessant für Dich. Und zwar ist mir aufgefallen, dass bei Sprüngen (getestet mit "wenn Anforderung vorliegt") in einigen Fällen die Anforderung gelöscht wird, aber der Sprung nicht durchgeführt wird. Das passiert immer dann, wenn die Anforderung ausgelöst wird, kurz (ca <= 0.5s) nachdem der Sprung im Ampelsystem abgefragt wurde. Das könnte hier in der Situation auch zu einer Fehlfunktion führen, wenns auch bei Sprüngen "ohne Anforderung" passiert. Das habe ich allerdings noch nicht getestet. Da der immer wiederholte Teil hier bloß eine Sekunde beträgt, und eventuell immer bis eine halbe Sekunde nach dem Sprung die Anforderung zwar gelöscht, aber nicht wirklich registriert wird, betrüge die Wahrscheinlichkeit hier schon starke 50%, dass die Anlage versagt.


    Testen kann man das ganz gut mit meinem Ampelkasten (da werden die blauen Leuchtmelder endlich mal wichtig. ^^), aber auch ein einfaches A-Signal könnte da schon Klärung schaffen. Wenn dieser Fehler auftritt, dann geht das A zwar an, aber die Schaltung reagiert nicht drauf, das Grün wird also nie kommen, weil die Anmeldung intern schon wieder gelöscht wurde.


    Leider ein etwas lästiger Fehler, weil sich Schaltungen mit verschiedenen gleichrangigen Anforderungen nicht anders umsetzen lassen, als dass man ein Stück der Schaltung immer wiederholt, und darin dann die verschiedenen möglichen Sprünge auf Anforderungen abfragt. Und damit die Reaktionszeit der Anlage nicht zu groß wird, muss logischerweise der wiederholte Zeitraum möglichst kurz werden, sodass dieser eigentlich recht unbedeutend wirkende Fehlerzeitraum von 0.5s doch ganz schön ins Gewicht fällt.

  • Im Prinzip ist die Schaltung, wie Du sie hast, schon in Ordnung. Kommt keine Bahn, dann wird das Grün übersprungen, kommt eine, sollte das Grün abgespielt werden. Vorausgesetzt, der Triggerpunkt funktioniert. Das kannste vielleicht mal testen, indem Du auch einen Schlüsselschalter einbindest. Mich verwundert aber etwas, dass, wie im ersten Bild zu sehen, die Grünphase auch als Rot1 eingestellt ist? Übersehe ich da was?

    Was das angeht, ist mir in den Bildern das auch aufgefallen, das mit den Rot.

    Und habe gleich wieder Nachgeschaut. Muss ein Anzeigefehler gewehsen sein, weil beim zweiten mal schauen wurde mir Grün1 angezeigt.



    Weiterhin würde ich die Schaltung hier auch etwas anders gestalten, auch wenn es so wie es jetzt ist eigentlich gehen müsste. Und zwar würde ich den Sprung weglassen, und stattdessen einen Stoppunkt in die Rotphase legen. Ebenfalls mit dem Häkchen "Falls keine Anforderung vorliegt". So wartet die Anlage immer in Stellung rot, außer es kommt eine Anforderung, dann wird sofort (und nicht erst mit im schlimmsten Falle einer Sekunde Verzögerung wie bei Dir, ist Geschmackssache) die Grünphase durchlaufen.

    Werde ich alles mal Probieren.




    Ergebnis:


    Nein Funktioniert nicht, dass "A" will einfach nicht anspringen.

    Habe es an mehrere Orte probiert, weil ich mal ein Fehler hatte das es Kachel bedingt war.

    Ich bauen einfach wild weiter, und warte weitere Updates ab.


    Aber danke für die ausführliche Erklärung @Kartoffelphantom

    Edited once, last by Amarin: Ergebnis ().

  • Mahlzeit,

    Amarin du willst/möchtest ne Schläfer LSA nachbauen ist das richtig ?/


    Mit kurz leuchtenden (A/K) wenn "Ja" schreibe ich dir nachher per Discord ;)

    VVM-Mitglied Abt.Tram am Schönberger Strand

    Erfahren auf HH V2/3 und Triebwagen 202

  • Mahlzeit,

    Amarin du willst/möchtest ne Schläfer LSA nachbauen ist das richtig ?/


    Mit kurz leuchtenden (A/K) wenn "Ja" schreibe ich dir nachher per Discord ;)


    Richtig, ich möchte das eine Reaktion via Trigger ausgelöst wird, und das automatisch.

    Dabei spielt das "A" oder andere Ampelzeichen keine große Rolle,

    es gibt genügend Gegenstände die genauso reagieren durch einer Bewegung.

    Wie eine Ampel an oder aus geht (also kurz was angezeigt wird, und dann wieder erlöscht).


    Die Ampel die ich erwähnte habe, ist nur ein Beispiel, weil ich es so besser erläutern kann.

  • OK alles klar melde mich nach dem Mittagessen bei dir ca 13:05;)


    Hab schon öfter Schläfer LSA auf meinem Projekt Team München verbaut ;p


    Die Linie 18 West hat bis zum Endpunkt 3 Schläfer LSA davon einer als Anwohner BÜ :)

    VVM-Mitglied Abt.Tram am Schönberger Strand

    Erfahren auf HH V2/3 und Triebwagen 202